FAQ

What is new in Say It Right 5.0?

How can I purchase Say It Right 5.0?

Do I have to pay for the delivery of the coursebook?

Can I access the course, before I receive the coursebook?

I forgot my password. What can I do?

I’d like to change my password

Can I use the application on multiple devices?

How do I perform deactivation?

I am logging into my account in the application, but I cannot access the content.

I am trying to log into the application, but I receive a message that I am already using the application on another device.

I have downloaded the application, but I cannot install it.

What is the language version of the interface?

If I purchase Say It Right 5.0, do I have access to only one language version of the interface?

Will I have to purchase other foreign language versions of the interface in the future?

Do I have to purchase the Standard British and General American variety separately?

Do I have to purchase the entire course?

I have downloaded the application, but it cannot be installed on my Mac computer.

I have downloaded the application for Windows, but the application cannot be installed on my computer

Here is a handful of useful information:

  1. If you have a running antivirus application, please, check whether it does not block the installation. If so, temporarily turn off the antivirus shield or add the app to the list of exclusions (Say It Right Online jest signed electronically and is free from viruses).
  2. In rare cases (usually when we update the app's electronic signature) you may see a Smart Screen ("The Windows System has protected this computer...") - which may hide underneath other windows and all other windows must be minimized in order to see it. If you see this screen, please, manually allow the installation to proceed.
  3. If the file setup.exe downloaded from the website is not working, please, try to install Say It Right from the following link: https://www.sayitrightonline.pl/DesktopApp/Say%20It%20Right%20Online.application . The system should recognize the file and initiate the installation after double clicking it.
  4. The correct functioning of Say It Right requires .NET Framework 4.5.2. The installer should detect it and install it automatically. If, for some reason, it fails to do so, the environment may be downloaded manually: https://www.microsoft.com/pl-pl/download/confirmation.aspx?id=42642

If all of the above methods fail, please, contact us.